summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-21 18:39:12 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-21 18:39:12 +0100
commit08892cdc5408e51f8e6a9ac316f7831a538ef123 (patch)
tree23986247a07dcf5ca8f6decb2e1970473842b522 /src/crypto/cipher/salsa20/nacl/CMakeLists.txt
parentc6cce0f5aac6640d5946c7ba7a258a04deac9423 (diff)
downloadfastd-08892cdc5408e51f8e6a9ac316f7831a538ef123.tar
fastd-08892cdc5408e51f8e6a9ac316f7831a538ef123.zip
Add salsa20 cipher
Diffstat (limited to 'src/crypto/cipher/salsa20/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/salsa20/nacl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/salsa20/nacl/CMakeLists.txt b/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
new file mode 100644
index 0000000..d76ff34
--- /dev/null
+++ b/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
@@ -0,0 +1,6 @@
+fastd_cipher_impl(salsa20 nacl
+ salsa20_nacl.c
+)
+fastd_cipher_impl_include_directories(salsa20 nacl ${NACL_INCLUDE_DIRS})
+fastd_cipher_impl_link_libraries(salsa20 nacl ${NACL_LIBRARIES})
+fastd_cipher_impl_require(salsa20 nacl NACL)