summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/salsa2012/nacl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-21 18:45:25 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-21 19:22:37 +0100
commit75e088559410b13e4400dcdbb817249543e4f8e5 (patch)
tree6792ad031b1a0afb3a05dafe36d1abbee04510cc /src/crypto/cipher/salsa2012/nacl/CMakeLists.txt
parent08892cdc5408e51f8e6a9ac316f7831a538ef123 (diff)
downloadfastd-75e088559410b13e4400dcdbb817249543e4f8e5.tar
fastd-75e088559410b13e4400dcdbb817249543e4f8e5.zip
Add salsa20/12 cipher
Diffstat (limited to 'src/crypto/cipher/salsa2012/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/salsa2012/nacl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/salsa2012/nacl/CMakeLists.txt b/src/crypto/cipher/salsa2012/nacl/CMakeLists.txt
new file mode 100644
index 0000000..3d47621
--- /dev/null
+++ b/src/crypto/cipher/salsa2012/nacl/CMakeLists.txt
@@ -0,0 +1,6 @@
+fastd_cipher_impl(salsa2012 nacl
+ salsa2012_nacl.c
+)
+fastd_cipher_impl_include_directories(salsa2012 nacl ${NACL_INCLUDE_DIRS})
+fastd_cipher_impl_link_libraries(salsa2012 nacl ${NACL_LIBRARIES})
+fastd_cipher_impl_require(salsa2012 nacl NACL)