summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
commit9bf498263765328011ee105e5e7b3e1cc1b2bc3f (patch)
treea6e18dfd838633e7444ae5deab8fc2b130780ec2 /src/crypto/mac/CMakeLists.txt
parentf2d84afd9d8373bf2778d1a1635384000c03f887 (diff)
downloadfastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.tar
fastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.zip
Experimental HMAC-SHA1 implementation
This adds experimental support for <cipher>+hmac-sha1 methods. It currently depends on OpenSSL and is not yet ready for production use.
Diffstat (limited to 'src/crypto/mac/CMakeLists.txt')
-rw-r--r--src/crypto/mac/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/crypto/mac/CMakeLists.txt b/src/crypto/mac/CMakeLists.txt
index 971c04b..77c813b 100644
--- a/src/crypto/mac/CMakeLists.txt
+++ b/src/crypto/mac/CMakeLists.txt
@@ -60,6 +60,7 @@ endmacro(fastd_mac_impl_compile_flags)
add_subdirectory(ghash)
+add_subdirectory(hmac_sha1)
set(MAC_DEFINITIONS "")