summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/hmac_sha1/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
commit9bf498263765328011ee105e5e7b3e1cc1b2bc3f (patch)
treea6e18dfd838633e7444ae5deab8fc2b130780ec2 /src/crypto/mac/hmac_sha1/CMakeLists.txt
parentf2d84afd9d8373bf2778d1a1635384000c03f887 (diff)
downloadfastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.tar
fastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.zip
Experimental HMAC-SHA1 implementation
This adds experimental support for <cipher>+hmac-sha1 methods. It currently depends on OpenSSL and is not yet ready for production use.
Diffstat (limited to 'src/crypto/mac/hmac_sha1/CMakeLists.txt')
-rw-r--r--src/crypto/mac/hmac_sha1/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/crypto/mac/hmac_sha1/CMakeLists.txt b/src/crypto/mac/hmac_sha1/CMakeLists.txt
new file mode 100644
index 0000000..10f0d35
--- /dev/null
+++ b/src/crypto/mac/hmac_sha1/CMakeLists.txt
@@ -0,0 +1,2 @@
+fastd_mac(hmac-sha1 hmac_sha1.c)
+add_subdirectory(openssl)