summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
commit095ca93d81cfae0fcb137919231810577c556404 (patch)
treea5ee059d61dd5c0483657105fb2f5400350f3150 /src/methods/CMakeLists.txt
parent5f6177e00fe4c56ece2cabdd61b772ed040c6e19 (diff)
downloadfastd-095ca93d81cfae0fcb137919231810577c556404.tar
fastd-095ca93d81cfae0fcb137919231810577c556404.zip
Organize method and protocol source files into distinct source directories
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
new file mode 100644
index 0000000..55f41d2
--- /dev/null
+++ b/src/methods/CMakeLists.txt
@@ -0,0 +1,19 @@
+set(METHODS null)
+
+if(WITH_METHOD_XSALSA20_POLY1305)
+ list(APPEND METHODS xsalsa20_poly1305)
+endif(WITH_METHOD_XSALSA20_POLY1305)
+
+if(WITH_METHOD_AES128_GCM)
+ list(APPEND METHODS aes128_gcm)
+endif(WITH_METHOD_AES128_GCM)
+
+
+set(METHOD_OBJECTS "")
+
+foreach(method ${METHODS})
+ add_subdirectory(${method})
+ list(APPEND METHOD_OBJECTS $<TARGET_OBJECTS:method_${method}>)
+endforeach(method)
+
+set(METHOD_OBJECTS "${METHOD_OBJECTS}" PARENT_SCOPE)