summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 14:34:01 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 14:34:01 +0100
commit20a95ef2731ce21acfe5c1ba97b40001217b0216 (patch)
treea41ed017d615a42771113fc9d7ee3df67652620f /src/methods/CMakeLists.txt
parent7a3c8bee42879add84a143ff98f28cbd0251dc7b (diff)
downloadfastd-20a95ef2731ce21acfe5c1ba97b40001217b0216.tar
fastd-20a95ef2731ce21acfe5c1ba97b40001217b0216.zip
Convert aes128-gcm into a generic gcm method
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
index c5a6273..d707884 100644
--- a/src/methods/CMakeLists.txt
+++ b/src/methods/CMakeLists.txt
@@ -6,10 +6,10 @@ if(WITH_METHOD_XSALSA20_POLY1305)
set(METHOD_COMMON TRUE)
endif(WITH_METHOD_XSALSA20_POLY1305)
-if(WITH_METHOD_AES128_GCM)
- list(APPEND METHODS aes128_gcm)
+if(WITH_METHOD_GENERIC_GCM)
+ list(APPEND METHODS generic_gcm)
set(METHOD_COMMON TRUE)
-endif(WITH_METHOD_AES128_GCM)
+endif(WITH_METHOD_GENERIC_GCM)
set(METHOD_SOURCES "${CMAKE_CURRENT_BINARY_DIR}/methods.c")