summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
commit9bf498263765328011ee105e5e7b3e1cc1b2bc3f (patch)
treea6e18dfd838633e7444ae5deab8fc2b130780ec2 /src/methods/CMakeLists.txt
parentf2d84afd9d8373bf2778d1a1635384000c03f887 (diff)
downloadfastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.tar
fastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.zip
Experimental HMAC-SHA1 implementation
This adds experimental support for <cipher>+hmac-sha1 methods. It currently depends on OpenSSL and is not yet ready for production use.
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
index f83f7b4..5bdd24c 100644
--- a/src/methods/CMakeLists.txt
+++ b/src/methods/CMakeLists.txt
@@ -26,6 +26,7 @@ add_subdirectory(null)
add_subdirectory(cipher_test)
add_subdirectory(composed_gmac)
add_subdirectory(generic_gmac)
+add_subdirectory(generic_hmac_sha1)
add_subdirectory(generic_poly1305)
add_subdirectory(xsalsa20_poly1305)