summaryrefslogtreecommitdiffstats
path: root/src/methods/generic_hmac_sha1/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
commit9bf498263765328011ee105e5e7b3e1cc1b2bc3f (patch)
treea6e18dfd838633e7444ae5deab8fc2b130780ec2 /src/methods/generic_hmac_sha1/CMakeLists.txt
parentf2d84afd9d8373bf2778d1a1635384000c03f887 (diff)
downloadfastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.tar
fastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.zip
Experimental HMAC-SHA1 implementation
This adds experimental support for <cipher>+hmac-sha1 methods. It currently depends on OpenSSL and is not yet ready for production use.
Diffstat (limited to 'src/methods/generic_hmac_sha1/CMakeLists.txt')
-rw-r--r--src/methods/generic_hmac_sha1/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/methods/generic_hmac_sha1/CMakeLists.txt b/src/methods/generic_hmac_sha1/CMakeLists.txt
new file mode 100644
index 0000000..b70bc1d
--- /dev/null
+++ b/src/methods/generic_hmac_sha1/CMakeLists.txt
@@ -0,0 +1,4 @@
+fastd_method(generic-hmac-sha1
+ generic_hmac_sha1.c
+)
+fastd_method_link_libraries(generic-hmac-sha1 method_common)