summaryrefslogtreecommitdiffstats
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
commit095ca93d81cfae0fcb137919231810577c556404 (patch)
treea5ee059d61dd5c0483657105fb2f5400350f3150 /src/protocols/CMakeLists.txt
parent5f6177e00fe4c56ece2cabdd61b772ed040c6e19 (diff)
downloadfastd-095ca93d81cfae0fcb137919231810577c556404.tar
fastd-095ca93d81cfae0fcb137919231810577c556404.zip
Organize method and protocol source files into distinct source directories
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
new file mode 100644
index 0000000..f033d32
--- /dev/null
+++ b/src/protocols/CMakeLists.txt
@@ -0,0 +1,10 @@
+set(PROTOCOLS ec25519_fhmqvc)
+
+set(PROTOCOL_OBJECTS "")
+
+foreach(protocol ${PROTOCOLS})
+ add_subdirectory(${protocol})
+ list(APPEND PROTOCOL_OBJECTS $<TARGET_OBJECTS:protocol_${protocol}>)
+endforeach(protocol)
+
+set(PROTOCOL_OBJECTS "${PROTOCOL_OBJECTS}" PARENT_SCOPE)