summaryrefslogtreecommitdiffstats
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 13:16:16 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 13:16:16 +0100
commit77b4733272c1677e774ee8bcb43b79272673bdea (patch)
tree7196fafc8c68ab8f541292f1c8f9e3dc2f2009fa /src/protocols/CMakeLists.txt
parentb117a60e81c3d67880cd8b0079041c92a0818d96 (diff)
downloadfastd-77b4733272c1677e774ee8bcb43b79272673bdea.tar
fastd-77b4733272c1677e774ee8bcb43b79272673bdea.zip
Include protocol as a static library as well
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
index 60bfa8e..a5be3f7 100644
--- a/src/protocols/CMakeLists.txt
+++ b/src/protocols/CMakeLists.txt
@@ -7,4 +7,4 @@ foreach(protocol ${PROTOCOLS})
list(APPEND PROTOCOL_SOURCES $<TARGET_OBJECTS:protocol_${protocol}>)
endforeach(protocol)
-set(PROTOCOL_SOURCES "${PROTOCOL_SOURCES}" PARENT_SCOPE)
+add_library(protocols STATIC ${PROTOCOL_SOURCES})