summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/crypto/cipher/CMakeLists.txt b/src/crypto/cipher/CMakeLists.txt
index 6cf6d64..3d70c70 100644
--- a/src/crypto/cipher/CMakeLists.txt
+++ b/src/crypto/cipher/CMakeLists.txt
@@ -16,9 +16,11 @@ macro(fastd_cipher_impl cipher name)
string(REPLACE - _ cipher_ "${cipher}")
string(TOUPPER "${cipher_}" CIPHER)
- set_property(GLOBAL APPEND PROPERTY FASTD_CIPHER_${CIPHER}_IMPLS ${name})
+ fastd_module(cipher enabled "cipher implementation" "${cipher} ${name}" ${ARGN})
- fastd_module(cipher "cipher implementation" "${cipher} ${name}" ${ARGN})
+ if(${enabled})
+ set_property(GLOBAL APPEND PROPERTY FASTD_CIPHER_${CIPHER}_IMPLS ${name})
+ endif(${enabled})
endmacro(fastd_cipher_impl)
macro(fastd_cipher_impl_include_directories cipher name)