summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/crypto/cipher/CMakeLists.txt b/src/crypto/cipher/CMakeLists.txt
index 3d70c70..addb28c 100644
--- a/src/crypto/cipher/CMakeLists.txt
+++ b/src/crypto/cipher/CMakeLists.txt
@@ -31,6 +31,10 @@ macro(fastd_cipher_impl_link_libraries cipher name)
fastd_module_link_libraries(cipher "${cipher} ${name}" ${ARGN})
endmacro(fastd_cipher_impl_link_libraries)
+macro(fastd_cipher_impl_require cipher name)
+ fastd_module_require(cipher "${cipher} ${name}" ${ARGN})
+endmacro(fastd_cipher_impl_require)
+
add_subdirectory(aes128_ctr)