summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
index ab0d0e8..50e2283 100644
--- a/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
+++ b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
@@ -1,5 +1,5 @@
-add_library(cipher_aes128_ctr_nacl OBJECT
+fastd_cipher_impl(aes128-ctr nacl
cipher_aes128_ctr_nacl.c
)
-set_property(TARGET cipher_aes128_ctr_nacl PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")
-target_include_directories(cipher_aes128_ctr_nacl PRIVATE ${NACL_INCLUDE_DIRS})
+fastd_cipher_impl_include_directories(aes128-ctr nacl ${NACL_INCLUDE_DIRS})
+fastd_cipher_impl_link_libraries(aes128-ctr nacl ${NACL_LIBRARIES})