summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/mac/ghash/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crypto/mac/ghash/CMakeLists.txt b/src/crypto/mac/ghash/CMakeLists.txt
new file mode 100644
index 0000000..7d697e8
--- /dev/null
+++ b/src/crypto/mac/ghash/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(IMPLS "")
+
+if(WITH_MAC_GHASH_BUILTIN)
+ list(APPEND IMPLS builtin)
+endif(WITH_MAC_GHASH_BUILTIN)
+
+set(IMPL_SOURCES "")
+
+foreach(impl ${IMPLS})
+ add_subdirectory(${impl})
+
+ list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:mac_ghash_${impl}>)
+endforeach(impl)
+
+
+set(MAC_NAME "ghash" PARENT_SCOPE)
+set(IMPLS "${IMPLS}" PARENT_SCOPE)
+set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)