summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/mac/ghash/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/crypto/mac/ghash/CMakeLists.txt b/src/crypto/mac/ghash/CMakeLists.txt
index 7d697e8..7d44b8a 100644
--- a/src/crypto/mac/ghash/CMakeLists.txt
+++ b/src/crypto/mac/ghash/CMakeLists.txt
@@ -1,18 +1,2 @@
-set(IMPLS "")
-
-if(WITH_MAC_GHASH_BUILTIN)
- list(APPEND IMPLS builtin)
-endif(WITH_MAC_GHASH_BUILTIN)
-
-set(IMPL_SOURCES "")
-
-foreach(impl ${IMPLS})
- add_subdirectory(${impl})
-
- list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:mac_ghash_${impl}>)
-endforeach(impl)
-
-
-set(MAC_NAME "ghash" PARENT_SCOPE)
-set(IMPLS "${IMPLS}" PARENT_SCOPE)
-set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)
+fastd_mac(ghash)
+add_subdirectory(builtin)