summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt b/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
new file mode 100644
index 0000000..cb08c58
--- /dev/null
+++ b/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(ENABLE_OPENSSL)
+ fastd_mac_impl(hmac-sha1 openssl
+ hmac_sha1_openssl.c
+ )
+ fastd_cipher_impl_include_directories(hmac-sha1 openssl ${OPENSSL_INCLUDE_DIRS})
+endif(ENABLE_OPENSSL)