summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
index 0060f7c..f67ea0c 100644
--- a/src/methods/CMakeLists.txt
+++ b/src/methods/CMakeLists.txt
@@ -1,9 +1,12 @@
add_library(methods STATIC "${CMAKE_CURRENT_BINARY_DIR}/methods.c")
-add_library(method_common STATIC "common.c")
+add_library(method_common STATIC EXCLUDE_FROM_ALL "common.c")
macro(fastd_method name)
- fastd_module(method "method" ${name} ${ARGN})
- set_property(GLOBAL APPEND PROPERTY FASTD_METHODS ${name})
+ fastd_module(method enabled "method" ${name} ${ARGN})
+
+ if(${enabled})
+ set_property(GLOBAL APPEND PROPERTY FASTD_METHODS ${name})
+ endif(${enabled})
endmacro(fastd_method)
macro(fastd_method_include_directories)