summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-03-18 17:14:11 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-03-18 17:14:11 +0100
commit70284a4ff2a28e1601f4390a01278ea900198bdd (patch)
treecdae787de6ec91be14a4546911f980e0243eba09 /src/CMakeLists.txt
downloadbabel-70284a4ff2a28e1601f4390a01278ea900198bdd.tar
babel-70284a4ff2a28e1601f4390a01278ea900198bdd.zip
Basic GMRF API implementation
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..e71a6a5
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,7 @@
+include_directories(${GMRF_INCLUDE_DIR})
+
+add_library(mmss_proto_babel MODULE
+ core.c
+)
+target_link_libraries(mmss_proto_babel ${MMSS_PROTOCOL_LIB})
+set_target_properties(mmss_proto_babel PROPERTIES LINK_FLAGS "-Wl,--undefined=mmss_protocol_info")