summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..cdf1ff9
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.6)
+project(HEADSHOT)
+
+find_package(OpenGL REQUIRED)
+
+include_directories(${OPENGL_INCLUDE_DIR})
+
+add_executable(headshot
+ Cuboid.h Cuboid.cpp
+ Engine.h Engine.cpp
+ gl.h
+ Keys.h
+ main.cpp
+ Triangle.h
+)
+target_link_libraries(headshot ${OPENGL_LIBRARIES} cwiid) \ No newline at end of file