summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2008-06-11 03:30:59 +0200
committerMatthias Schiffer <matthias@gamezock.de>2008-06-11 03:30:59 +0200
commit86315eee08beea75d92eb506d46de4d357ec659a (patch)
treefdc8c4e131056d766df01f74353e0e7e03d40588 /configure.ac
parentfda583fd83f27d6754891a77c24bdec9ddc19d4f (diff)
downloadmad-86315eee08beea75d92eb506d46de4d357ec659a.tar
mad-86315eee08beea75d92eb506d46de4d357ec659a.zip
Build-Infrastruktur erstellt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ad5e36c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,32 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(mad, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([src/madc.cpp])
+AM_CONFIG_HEADER([src/config.h])
+
+AM_INIT_AUTOMAKE(mad, 0.1)
+AM_MAINTAINER_MODE
+AC_DISABLE_STATIC
+
+# Checks for programs.
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+
+AC_OUTPUT
+