summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-05-19 09:13:35 +0200
committerMatthias Schiffer <matthias@gamezock.de>2009-05-19 09:13:35 +0200
commitbadc0da3b74d99c90b7b28180d08cd6d08830254 (patch)
treebf4acef89fd445b0e406c0bebbf60fc7ff467fce /configure.ac
parent1cfbc7298525656701f32224e1ed42a3e835835a (diff)
downloadmad-badc0da3b74d99c90b7b28180d08cd6d08830254.tar
mad-badc0da3b74d99c90b7b28180d08cd6d08830254.zip
Make-Prozess auf CMake umgestellt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac123
1 files changed, 0 insertions, 123 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index ec2570c..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,123 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.61)
-AC_INIT(mad, 0.1, matthias@gamezock.de)
-AC_CONFIG_AUX_DIR([config])
-AC_CONFIG_SRCDIR([src/mad.cpp])
-AC_CONFIG_HEADERS([config.h])
-
-AM_INIT_AUTOMAKE(mad, 0.1)
-AM_MAINTAINER_MODE
-
-# Checks for programs.
-AC_PROG_CXX
-AC_PROG_CC
-AC_PROG_CPP
-AC_PROG_INSTALL
-AC_PROG_LN_S
-AC_PROG_MAKE_SET
-AC_CHECK_PROG(have_df, [df], yes, no)
-
-ORIG_LIBS=$LIBS
-
-LT_CONFIG_LTDL_DIR([libltdl])
-LT_INIT([dlopen])
-LTDL_INIT([recursive])
-AC_SUBST(LIBLTDL)
-
-AM_CONDITIONAL(INCLUDED_LTDL, test "x$with_included_ltdl" = xyes)
-
-# Checks for libraries.
-PKG_CHECK_MODULES(libxml2, libxml-2.0, , AC_MSG_ERROR(Test for libxml 2.0 failed.))
-PKG_CHECK_MODULES(GnuTLS, gnutls, , AC_MSG_ERROR(Test for GnuTLS failed.))
-
-AX_LIB_MYSQL
-AX_BOOST_BASE
-AX_BOOST_REGEX
-AX_BOOST_SIGNALS
-AX_BOOST_THREAD
-
-
-CPPFLAGS='-I$(top_builddir)/lib -I$(top_srcdir)/lib -I${top_srcdir}/src '"$libxml2_CFLAGS $GnuTLS_CFLAGS $MYSQL_CFLAGS $BOOST_CPPFLAGS $INCLTDL $CPPFLAGS"
-
-AC_CHECK_LIB(gssapi_krb5, gss_init_sec_context, AC_SUBST(GSSAPI_LIBS, -lgssapi_krb5), AC_CHECK_LIB(gssapi, gss_init_sec_context, GSSAPI_LIBS=-lgssapi, AC_MSG_ERROR(Test for GSSAPI library failed.)))
-AC_CHECK_LIB(readline, readline, AC_SUBST(READLINE_LIBS, -lreadline), AC_MSG_ERROR(Test for GNU readline library failed.))
-
-LIBS=$ORIG_LIBS
-
-# Checks for header files.
-AC_HEADER_DIRENT
-AC_HEADER_STDC
-AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([argz.h arpa/inet.h fcntl.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
-AC_TYPE_PID_T
-AC_TYPE_SIZE_T
-AC_TYPE_SSIZE_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-AC_TYPE_UINT64_T
-AC_TYPE_UINT8_T
-
-# Checks for library functions.
-AC_FUNC_MALLOC
-AC_HEADER_STDC
-AC_FUNC_REALLOC
-AC_TYPE_SIGNAL
-AC_CHECK_FUNCS([dup2 gethostname memmove memset socket strcasecmp strchr strdup strerror strrchr strtol])
-
-if test x"$with_systembackend_proc" = x; then
- with_systembackend_proc=no
- AC_CHECK_FILES([/proc/uptime /proc/meminfo /proc/loadavg], with_systembackend_proc=yes)
-fi
-
-AC_ARG_WITH([systembackend_posix], [AS_HELP_STRING([--with-systembackend-posix],
- [enable POSIX system backend @<:@default=yes@:>@])])
-AC_ARG_WITH([systembackend_proc], [AS_HELP_STRING([--with-systembackend-proc],
- [enable /proc system backend])])
-AC_ARG_WITH([userbackend_mysql], [AS_HELP_STRING([--with-userbackend-mysql],
- [enable MySQL user backend @<:@default=yes@:>@])])
-
-AC_CHECK_FUNCS([posix_spawnp], , [with_systembackend_posix=no])
-if test x"$have_df" = xno; then
- with_systembackend_posix=no
-fi
-
-if test x"$found_mysql" = xno; then
- with_userbackend_mysql=no
-fi
-
-AM_CONDITIONAL(SYSTEMBACKEND_POSIX, test x"$with_systembackend_posix" != xno)
-AM_CONDITIONAL(SYSTEMBACKEND_PROC, test x"$with_systembackend_proc" != xno)
-AM_CONDITIONAL(USERBACKEND_MYSQL, test x"$with_userbackend_mysql" != xno)
-
-
-AC_DEFINE([_UNUSED_PARAMETER_], [__attribute__((unused))], [Unused parameters])
-
-
-AC_CONFIG_FILES([
- Makefile
- libltdl/Makefile
- src/Makefile
- src/Client/Makefile
- src/Client/Requests/Makefile
- src/Common/Makefile
- src/Common/Requests/Makefile
- src/Common/RequestHandlers/Makefile
- src/Daemon/Makefile
- src/Daemon/Backends/Makefile
- src/Daemon/Requests/Makefile
- src/Daemon/RequestHandlers/Makefile
- src/Net/Makefile
- src/Server/Makefile
- src/Server/Requests/Makefile
- src/Server/RequestHandlers/Makefile
- src/modules/Makefile
-])
-
-AC_OUTPUT
-