summaryrefslogtreecommitdiffstats
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2008-12-08 22:03:45 +0100
committerMatthias Schiffer <matthias@gamezock.de>2008-12-08 22:03:45 +0100
commit60f1e0a3942adba1505a8d56064b3cc53834045d (patch)
treead144073779b0143e54fc1ea642b17be074a8547 /src/modules/Makefile.am
parentad7ee8df8ac73ef7754ccf1d5fb442ec23c879f1 (diff)
downloadmad-60f1e0a3942adba1505a8d56064b3cc53834045d.tar
mad-60f1e0a3942adba1505a8d56064b3cc53834045d.zip
Kann jetzt mit preopen ge?ffnete Module laden
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
index 18d8ad6..40e15cc 100644
--- a/src/modules/Makefile.am
+++ b/src/modules/Makefile.am
@@ -2,11 +2,12 @@ madlibdir = ${libdir}/mad
moddir = ${madlibdir}/modules
mod_LTLIBRARIES = SystemBackendPosix.la SystemBackendProc.la
-AM_LDFLAGS = -module -avoid-version -export-dynamic
SystemBackendPosix_la_SOURCES = SystemBackendPosix.cpp
SystemBackendPosix_la_LIBADD = $(sigc_LIBS)
+SystemBackendPosix_la_LDFLAGS = -module -avoid-version -export-dynamic -static -export-symbols-regex '^SystemBackendPosix_LTX_'
SystemBackendProc_la_SOURCES = SystemBackendProc.cpp
+SystemBackendProc_la_LDFLAGS = -module -avoid-version -export-dynamic -static -export-symbols-regex '^SystemBackendProc_LTX_'
noinst_HEADERS = SystemBackendPosix.h SystemBackendProc.h