summaryrefslogtreecommitdiffstats
path: root/src/modules/UserListManager/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-09-15 16:11:54 +0200
committerMatthias Schiffer <matthias@gamezock.de>2009-09-15 16:11:54 +0200
commit2ba5228d0483798a9e122670d15a078c4478898f (patch)
tree5c4a46d6410d866afc94f6d2ce0aeb99665ae831 /src/modules/UserListManager/CMakeLists.txt
parent7f4f260d732c849c1e88fcb91023faab5316d9c6 (diff)
downloadmad-2ba5228d0483798a9e122670d15a078c4478898f.tar
mad-2ba5228d0483798a9e122670d15a078c4478898f.zip
Added UserListManager module
Diffstat (limited to 'src/modules/UserListManager/CMakeLists.txt')
-rw-r--r--src/modules/UserListManager/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/modules/UserListManager/CMakeLists.txt b/src/modules/UserListManager/CMakeLists.txt
new file mode 100644
index 0000000..0ab429f
--- /dev/null
+++ b/src/modules/UserListManager/CMakeLists.txt
@@ -0,0 +1,14 @@
+include_directories(${INCLUDES})
+
+mad_module(UserListManager
+ RequestHandlers/UserListRequestHandlerGroup.cpp RequestHandlers/UserListRequestHandlerGroup.h
+ RequestHandlers/UserListUploadRequestHandler.cpp RequestHandlers/UserListUploadRequestHandler.h
+
+ Module.cpp Module.h
+ UserList.h
+ UserListEntry.h
+ UserListManager.cpp UserListManager.h
+ Util.cpp Util.h
+)
+
+mad_module_libraries(UserListManager)