summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f72352b..d859809 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,14 +12,19 @@ find_package(KRB5 COMPONENTS krb5 kadm-client)
if(WIN32)
add_definitions(-DWINVER=0x0501 -D_WIN32_WINNT=0x0501)
+
+ if(CYGWIN)
+ add_definitions(-D__USE_W32_SOCKETS)
+ endif(CYGWIN)
+
+ if(NOT MSVC)
+ set(Boost_LIBRARIES ${Boost_LIBRARIES} -lws2_32 -lwsock32)
+ endif(NOT MSVC)
+
else(WIN32)
find_package(DL REQUIRED)
endif(WIN32)
-if(CYGWIN)
- add_definitions(-D__USE_W32_SOCKETS)
-endif(CYGWIN)
-
configure_file(${MAD_SOURCE_DIR}/config.h.in ${MAD_BINARY_DIR}/config.h)
set(INCLUDES