summaryrefslogtreecommitdiffstats
path: root/src/Client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Client/CMakeLists.txt')
-rw-r--r--src/Client/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/Client/CMakeLists.txt b/src/Client/CMakeLists.txt
index 6d7ba4c..fcd6f6b 100644
--- a/src/Client/CMakeLists.txt
+++ b/src/Client/CMakeLists.txt
@@ -1,12 +1,18 @@
-add_subdirectory(Requests)
-
include_directories(${INCLUDES})
-add_library(Client
+mad_library(Client
+ export.h
+
+ Requests/DaemonCommandRequest.h Requests/DaemonCommandRequest.cpp
+ Requests/DaemonFSInfoRequest.h Requests/DaemonFSInfoRequest.cpp
+ Requests/DaemonListRequest.h
+ Requests/DaemonStatusRequest.h Requests/DaemonStatusRequest.cpp
+
Application.cpp Application.h
CommandParser.cpp CommandParser.h
InformationManager.cpp InformationManager.h
+ PasswordReader.cpp PasswordReader.h
SystemCommands.cpp SystemCommands.h
UserCommands.cpp UserCommands.h
)
-target_link_libraries(Client ClientRequests Common)
+target_link_libraries(Client Common)