summaryrefslogtreecommitdiffstats
path: root/src/Common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Common/CMakeLists.txt')
-rw-r--r--src/Common/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Common/CMakeLists.txt b/src/Common/CMakeLists.txt
new file mode 100644
index 0000000..e2f7b4b
--- /dev/null
+++ b/src/Common/CMakeLists.txt
@@ -0,0 +1,14 @@
+add_subdirectory(RequestHandlers)
+add_subdirectory(Requests)
+
+
+include_directories(${INCLUDES})
+link_directories(${LTDL_LIBRARY_DIR})
+
+add_library(Common
+ ActionManager.cpp Base64Encoder.cpp ClientConnection.cpp ConfigEntry.cpp
+ ConfigManager.cpp Connection.cpp Initializable.cpp Logger.cpp LogManager.cpp
+ ModuleManager.cpp Request.cpp RequestManager.cpp SystemManager.cpp Tokenizer.cpp
+ XmlPacket.cpp
+)
+target_link_libraries(Common RequestHandlers Requests Net ${LIBXML2_LIBRARIES} ${LTDL_LIBRARIES})