summaryrefslogtreecommitdiffstats
path: root/src/Common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Common/Makefile.am')
-rw-r--r--src/Common/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Common/Makefile.am b/src/Common/Makefile.am
index f04f3db..88126c4 100644
--- a/src/Common/Makefile.am
+++ b/src/Common/Makefile.am
@@ -1,6 +1,7 @@
-SUBDIRS = Request
+SUBDIRS = Backends Requests RequestHandlers
noinst_LTLIBRARIES = libcommon.la
-libcommon_la_SOURCES = ConfigManager.cpp RequestManager.cpp
+libcommon_la_SOURCES = ConfigManager.cpp Exception.cpp Logger.cpp RequestManager.cpp SystemBackend.cpp Util.cpp
+libcommon_la_LIBADD = Backends/libbackends.la Requests/librequests.la RequestHandlers/librequesthandlers.la
-noinst_HEADERS = ConfigManager.h RequestHandler.h RequestManager.h Util.h
+noinst_HEADERS = ConfigManager.h Exception.h Logger.h Request.h RequestBase.h RequestHandler.h RequestManager.h SystemBackend.h Util.h