summaryrefslogtreecommitdiffstats
path: root/src/Net/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Net/Makefile.am')
-rw-r--r--src/Net/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Net/Makefile.am b/src/Net/Makefile.am
index c7f58da..2fd4f12 100644
--- a/src/Net/Makefile.am
+++ b/src/Net/Makefile.am
@@ -1,6 +1,8 @@
-noinst_LTLIBRARIES = libnet.la
+SUBDIRS = Packets
-libnet_la_SOURCES = ClientConnection.cpp ServerConnection.cpp Connection.cpp Listener.cpp
+noinst_LTLIBRARIES = libnet.la
+libnet_la_SOURCES = ClientConnection.cpp ServerConnection.cpp Connection.cpp Listener.cpp Packet.cpp
+libnet_la_LIBADD = Packets/libpackets.la
noinst_HEADERS = ClientConnection.h ServerConnection.h Connection.h Exception.h ConnectionException.h \
InvalidAddressException.h IPAddress.h Listener.h Packet.h