summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2019-05-31 18:42:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2019-05-31 18:42:01 +0200
commitbcef77a7fb3b73d2a2fbcea51012014b62755bb5 (patch)
tree3a5935014a6a2569e592f40086f7858d1207c66c /src/meson.build
parent44cb17317c40fa9d39b3402f0826006f20387be5 (diff)
downloadneco-bcef77a7fb3b73d2a2fbcea51012014b62755bb5.tar
neco-bcef77a7fb3b73d2a2fbcea51012014b62755bb5.zip
Switch to a JSON-based config format
We can get rid of a lot of code by ditching out INI format parser. We also remove the support for "subtype" and "generator" templates for now; rather than implementing this in NeCo itself, templates could be implemented as a Lua DSL later.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 9056cf3..b359ab4 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,19 +1,18 @@
src = [
'neco.c',
- 'config-ini.c',
'config-load.c',
'config-process.c',
'device.c',
'device-bridge.c',
'device-interface.c',
- 'keywords.c',
'netlink.c',
'vector.c',
]
dep = [
- libubox_dep,
+ libjson_c_dep,
libmnl_dep,
+ libubox_dep,
]
executable('neco', sources: src, dependencies: dep)