summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2019-01-05 22:06:45 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2019-01-05 22:06:45 +0100
commitdaa68c4b2de9814b8331e7b9079d5fc49bee35c1 (patch)
tree4f82de8a19abf7b6a0c9e6f511ac23995d9d5851 /src/meson.build
parent9e059f898ae1b0528cdde553fd51c661901e283a (diff)
downloadneco-daa68c4b2de9814b8331e7b9079d5fc49bee35c1.tar
neco-daa68c4b2de9814b8331e7b9079d5fc49bee35c1.zip
Add first parts of interface config handling
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index c24ca21..b088e39 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,7 +1,13 @@
src = [
- 'pnc.c',
+ 'neco.c',
'config-ini.c',
'config-load.c',
+ 'config-process.c',
+ 'device.c',
+ 'device-bridge.c',
+ 'device-interface.c',
+ 'keywords.c',
+ 'vector.c',
]
-executable('pnc', sources: src, dependencies: [ubox_dep])
+executable('neco', sources: src, dependencies: [ubox_dep])