summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8e184d9
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,48 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(libzoom, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([player.c])
+AM_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE(libzoom, 0.1)
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LIBTOOL
+PKG_PROG_PKG_CONFIG
+
+# Checks for libraries.
+AX_CHECK_GL
+if test x$no_gl = xyes; then
+ AC_MSG_ERROR([OpenGL Library not found])
+fi
+
+AX_CHECK_GLU
+if test x$no_gl = xyes; then
+ AC_MSG_ERROR([OpenGL Utility Library not found])
+fi
+
+PKG_CHECK_MODULES(libneofx, libneofx-0.1, , AC_MSG_ERROR(Test for libneofx failed.))
+PKG_CHECK_MODULES(libpng, libpng, , AC_MSG_ERROR(Test for libpng failed.))
+PKG_CHECK_MODULES(libxml2, libxml-2.0, , AC_MSG_ERROR(Test for libxml2 failed.))
+
+CFLAGS="$GL_CFLAGS $GLU_CFLAGS $libneofx_CFLAGS $libpng_CFLAGS $libxml2_CFLAGS $CFLAGS"
+LIBS="$GL_LIBS $GLU_LIBS $libneofx_LIBS $libpng_LIBS $libxml2_LIBS $LIBS"
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+#AC_CHECK_FUNCS([strcasecmp], , AC_MSG_ERROR([required function strcasecmp not found]))
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT([libzoom-0.1.pc])