summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..0fbb214
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,44 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(libzoom, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([player.c])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE(libzoom, 0.1)
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+AX_CHECK_GL
+if test x$no_gl = xyes; then
+ AC_MSG_ERROR([OpenGL Library not found])
+fi
+
+AX_CHECK_GLU
+if test x$no_gl = xyes; then
+ AC_MSG_ERROR([OpenGL Utility Library not found])
+fi
+
+#CFLAGS="$CFLAGS $GL_CFLAGS $GLU_CFLAGS"
+#LIBS="$LIBS $GL_LIBS $GLU_LIBS"
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([sqrt], , AC_MSG_ERROR([required function sqrt not found]))
+AC_CHECK_FUNCS([strcasecmp], , AC_MSG_ERROR([required function strcasecmp not found]))
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT