summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-12-13 18:49:36 +0100
committerMatthias Schiffer <matthias@gamezock.de>2009-12-13 18:49:36 +0100
commitda66d49b8a7bcc808df201bee5c7cb787b6f30b7 (patch)
tree2ded525251ba7b8dfd812edd8a0a29d06a6a3106 /CMakeLists.txt
downloadzoom++-da66d49b8a7bcc808df201bee5c7cb787b6f30b7.tar
zoom++-da66d49b8a7bcc808df201bee5c7cb787b6f30b7.zip
Basic infrastructure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..da27b7b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.6)
+project(ZOOM)
+
+find_package(OpenGL REQUIRED)
+
+include_directories(${OPENGL_INCLUDE_DIR})
+
+add_executable(zoom
+ BSPTree.cpp BSPTree.h
+ Game.cpp Game.h
+ config.h
+ gl.h
+ Renderer.cpp Renderer.h
+ Triangle.h
+ zoom.cpp
+)
+
+target_link_libraries(zoom ${OPENGL_LIBRARIES})