summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-12-16 14:58:56 +0100
committerMatthias Schiffer <matthias@gamezock.de>2009-12-16 14:58:56 +0100
commitea08fea654b4702a77f623b74137fabc7d6800d8 (patch)
tree7550e20704ee9a93e6b1ea95d72563250956ac17 /src/CMakeLists.txt
parenta407f8b9edbc7a6e865b2daf65b2a6cd10edd2d7 (diff)
downloadzoom++-ea08fea654b4702a77f623b74137fabc7d6800d8.tar
zoom++-ea08fea654b4702a77f623b74137fabc7d6800d8.zip
Use perspective projection matrix without far clipping plane.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e1c9378..6b56713 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,10 +4,11 @@ add_executable(zoom
config.h
gl.h
Level.cpp Level.h
+ MathUtil.cpp MathUtil.h
Renderer.cpp Renderer.h
Shader.cpp Shader.h
Texture.cpp Texture.h
Triangle.h
zoom.cpp
)
-target_link_libraries(zoom ${Boost_LIBRARIES} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLPNG_LIBRARY} ${LIBXML2_LIBRARIES})
+target_link_libraries(zoom ${Boost_LIBRARIES} ${OPENGL_gl_LIBRARY} ${GLEW_LIBRARY} ${GLPNG_LIBRARY} ${LIBXML2_LIBRARIES})