summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da27b7b..6135c41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,25 @@
cmake_minimum_required(VERSION 2.6)
project(ZOOM)
+set(CMAKE_MODULE_PATH ${ZOOM_SOURCE_DIR})
+
+find_package(Boost REQUIRED)
find_package(OpenGL REQUIRED)
+find_package(GLPng REQUIRED)
+find_package(LibXml2 REQUIRED)
-include_directories(${OPENGL_INCLUDE_DIR})
+include_directories(${Boost_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR} ${GLPNG_INCLUDE_DIR} ${LIBXML2_INCLUDE_DIR})
add_executable(zoom
BSPTree.cpp BSPTree.h
Game.cpp Game.h
config.h
gl.h
+ Level.cpp Level.h
Renderer.cpp Renderer.h
+ Texture.cpp Texture.h
Triangle.h
zoom.cpp
)
-target_link_libraries(zoom ${OPENGL_LIBRARIES})
+target_link_libraries(zoom ${Boost_LIBRARIES} ${OPENGL_LIBRARIES} ${GLPNG_LIBRARY} ${LIBXML2_LIBRARIES})