summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorneoraider <devnull@localhost>2007-06-21 21:52:03 +0200
committerneoraider <devnull@localhost>2007-06-21 21:52:03 +0200
commit84361f7a9e03f76e7ea90f48239825dc5bca07e9 (patch)
tree60eb7a4611cef032d0d4689f2fc19a769353c8e1 /configure.in
downloadzoomedit-84361f7a9e03f76e7ea90f48239825dc5bca07e9.tar
zoomedit-84361f7a9e03f76e7ea90f48239825dc5bca07e9.zip
zoomedit: Added level editor zoomedit.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..d09382d
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,35 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(zoomedit, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([zoomedit.c])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE(zoomedit, 0.1)
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_C_O
+#AC_PROG_LIBTOOL
+
+# Checks for libraries.
+#AC_CHECK_LIB(m, [sqrt])
+AM_PATH_GTK_2_0(2.8.0,,AC_MSG_ERROR(zoomedit needs GTK+ 2.8.0))
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+#AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+
+#AC_CHECK_FUNCS([sqrtf], , AC_MSG_ERROR([required function sqrtf not found]))
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT