summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a30cd6c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(zoomedit, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([zoomedit.cpp])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE(zoomedit, 0.1)
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+#AC_CHECK_LIB(m, [sqrt])
+PKG_CHECK_MODULES(glademm, libglademm-2.4, , AC_MSG_ERROR(Test for libglademm-2.4 failed.))
+AM_PATH_GTKGLEXT_1_0(1.0.0,,AC_MSG_ERROR(Test for GtkGLExt failed.))
+#PKG_CHECK_MODULES(libxml2, libxml-2.0, , AC_MSG_ERROR(Test for libxml2 failed.))
+
+
+# Checks for header files.
+#AC_HEADER_STDC
+#AC_CHECK_HEADERS([stddef.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+#AC_HEADER_TIME
+
+# Checks for library functions.
+#AC_FUNC_MALLOC
+#AC_FUNC_REALLOC
+
+#AC_CHECK_FUNCS([sqrtf], , AC_MSG_ERROR([required function sqrtf not found]))
+
+AC_CONFIG_FILES([Makefile Gui/Makefile])
+AC_OUTPUT