summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-08-30 18:49:22 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-08-30 18:49:22 +0200
commit2798254db8ac54abc8ab73a7242a37865fcc9147 (patch)
treefb319a87f5aad4bae21556722157b3420b5340ec
parent232e35eb40faf9ce8b3516bb5ea1986a8507db37 (diff)
downloadmeta-gluon-2798254db8ac54abc8ab73a7242a37865fcc9147.tar
meta-gluon-2798254db8ac54abc8ab73a7242a37865fcc9147.zip
musl: add minification patch from OpenWrt
-rw-r--r--recipes-core/musl/musl/iconv_size_hack.patch68
-rw-r--r--recipes-core/musl/musl_git.bbappend7
2 files changed, 75 insertions, 0 deletions
diff --git a/recipes-core/musl/musl/iconv_size_hack.patch b/recipes-core/musl/musl/iconv_size_hack.patch
new file mode 100644
index 0000000..343915f
--- /dev/null
+++ b/recipes-core/musl/musl/iconv_size_hack.patch
@@ -0,0 +1,68 @@
+--- a/src/locale/iconv.c
++++ b/src/locale/iconv.c
+@@ -39,6 +39,7 @@ static const unsigned char charmaps[] =
+ "ucs4\0ucs4be\0utf32\0utf32be\0\0\300"
+ "ucs4le\0utf32le\0\0\303"
+ "ascii\0usascii\0iso646\0iso646us\0\0\307"
++#ifdef FULL_ICONV
+ "eucjp\0\0\320"
+ "shiftjis\0sjis\0\0\321"
+ "gb18030\0\0\330"
+@@ -46,6 +47,7 @@ static const unsigned char charmaps[] =
+ "gb2312\0\0\332"
+ "big5\0bigfive\0cp950\0big5hkscs\0\0\340"
+ "euckr\0ksc5601\0ksx1001\0cp949\0\0\350"
++#endif
+ #include "codepages.h"
+ ;
+
+@@ -53,6 +55,7 @@ static const unsigned short legacy_chars
+ #include "legacychars.h"
+ };
+
++#ifdef FULL_ICONV
+ static const unsigned short jis0208[84][94] = {
+ #include "jis0208.h"
+ };
+@@ -72,6 +75,7 @@ static const unsigned short hkscs[] = {
+ static const unsigned short ksc[93][94] = {
+ #include "ksc.h"
+ };
++#endif
+
+ static int fuzzycmp(const unsigned char *a, const unsigned char *b)
+ {
+@@ -216,6 +220,7 @@ size_t iconv(iconv_t cd0, char **restric
+ c = ((c-0xd7c0)<<10) + (d-0xdc00);
+ }
+ break;
++#ifdef FULL_ICONV
+ case SHIFT_JIS:
+ if (c-0xa1 <= 0xdf-0xa1) {
+ c += 0xff61-0xa1;
+@@ -362,6 +367,7 @@ size_t iconv(iconv_t cd0, char **restric
+ c = ksc[c][d];
+ if (!c) goto ilseq;
+ break;
++#endif
+ default:
+ if (c < 128+type) break;
+ c -= 128+type;
+--- a/src/locale/codepages.h
++++ b/src/locale/codepages.h
+@@ -118,6 +118,7 @@
+ "\0\0\0\100\15\0\344\0\0\0\0\0\0\0\0\0\0\0\0\0\103\270\1\0\0\0\340\1\200\40"
+ "\230\0\0\0\0\0\44\341\12\0"
+
++#ifdef FULL_ICONV
+ "cp1250\0"
+ "windows1250\0"
+ "\0\0"
+@@ -214,6 +215,7 @@
+ "\0\0\0\0\0\0\0\0\0\15\0\0\0\0\0\0\0\0\0\0\266\0\0\0\0\102\0\220\13\0"
+ "\0\234\2\0\0\0\0\0\0\0\0\244\202\13\0\0\0\0\100\15\0\0\0\0\0\0\0\0\0\0"
+ "\267\0\0\0\0\103\0\240\13\0\0\240\2\0\0\0\0\0\0\0\0\250\62\45\0"
++#endif
+
+ "koi8r\0"
+ "\0\0"
diff --git a/recipes-core/musl/musl_git.bbappend b/recipes-core/musl/musl_git.bbappend
new file mode 100644
index 0000000..741b467
--- /dev/null
+++ b/recipes-core/musl/musl_git.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+PACKAGECONFIG[minimal_iconv] = ",,"
+
+SRC_URI += "\
+ ${@bb.utils.contains('PACKAGECONFIG', 'minimal_iconv', 'file://iconv_size_hack.patch', '', d)} \
+ "