summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-11-28 19:15:17 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-11-28 19:16:01 +0100
commit3a8cf86a60a78da66cd17c9670b961bf9fa11aa4 (patch)
tree2d841d8364f5cc8fadc75617a219fdc6d4f1b1c8
parent6bdc2c4521091a73686ca6043c28d7d5a95d5abe (diff)
downloadmeta-gluon-3a8cf86a60a78da66cd17c9670b961bf9fa11aa4.tar
meta-gluon-3a8cf86a60a78da66cd17c9670b961bf9fa11aa4.zip
Minor merged-usr updates
-rw-r--r--recipes-core/base-files/base-files_%.bbappend2
-rw-r--r--recipes-core/busybox/busybox_%.bbappend5
2 files changed, 2 insertions, 5 deletions
diff --git a/recipes-core/base-files/base-files_%.bbappend b/recipes-core/base-files/base-files_%.bbappend
index 407658d..b8d5d07 100644
--- a/recipes-core/base-files/base-files_%.bbappend
+++ b/recipes-core/base-files/base-files_%.bbappend
@@ -24,6 +24,6 @@ do_install_append_merged-usr () {
fi
if [ "${bindir}" = "${exec_prefix}/bin" -a "${sbindir}" = "${exec_prefix}/bin" ]; then
- ln -snf bin ${D}/usr/sbin
+ ln -snf bin ${D}${exec_prefix}/sbin
fi
}
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
index 3c3d7f0..87a275d 100644
--- a/recipes-core/busybox/busybox_%.bbappend
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -146,11 +146,8 @@ pkg_postinst_${PN} () {
if test ! -e "$link"; then
# we can use busybox here because even if we are using splitted busybox
# we've made a symlink from /bin/busybox to /bin/busybox.nosuid.
- # The sed expression will fail if ${base_bindir}, ${base_sbindir}, ${bindir} or
- # ${sbindir} contains . or .., so don't do that!
- to="$(echo -n "$link" | busybox sed -r -e 's@^/[^/]+/@@' -e 's@[^/]+@..@g')${base_bindir}/busybox$suffix"
busybox rm -f $link
- busybox ln -s $to $link
+ busybox ln -s "${base_bindir}/busybox$suffix" $link
fi
done < /etc/busybox.links$suffix
fi