summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-02-10 23:52:46 +0100
committerFelix Fietkau <nbd@openwrt.org>2013-02-10 23:52:46 +0100
commit0e1ddb8cc10fab53958d5a73329efefaa49b7b12 (patch)
tree219ae97d69f3ae2835e50b98202295ee26f5082d /CMakeLists.txt
parent38d78cba6ed4b42b0c1134bf05885d7e09537fde (diff)
downloadunitd-0e1ddb8cc10fab53958d5a73329efefaa49b7b12.tar
unitd-0e1ddb8cc10fab53958d5a73329efefaa49b7b12.zip
hotplug: add parser for new hotplug event rulesets (work in progress, not integrated yet)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac88616..fc1ad3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,9 +10,10 @@ IF(APPLE)
LINK_DIRECTORIES(/opt/local/lib)
ENDIF()
-SET(SOURCES main.c ubus.c service.c instance.c utils.c md5.c)
+SET(SOURCES main.c ubus.c service.c instance.c utils.c md5.c hotplug-rule.c hotplug.c)
-SET(LIBS ubox ubus)
+find_library(json NAMES json-c json)
+SET(LIBS ubox ubus ${json} blobmsg_json)
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)