summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-10 17:50:15 +0200
committerJohn Crispin <blogic@openwrt.org>2014-06-11 00:06:12 +0200
commit13259259bc53657617844660f2664f4b4fb4ac02 (patch)
treeec7e121e780ddfd1923e48d7d17243241b213948 /CMakeLists.txt
parent53c1ea6b9ade10eff3cec07519db862b365a4233 (diff)
downloadunitd-13259259bc53657617844660f2664f4b4fb4ac02.tar
unitd-13259259bc53657617844660f2664f4b4fb4ac02.zip
add upgraded support for nand flashing
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c89947..2b72ad3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,14 @@ INSTALL(TARGETS udevtrigger
)
+ADD_EXECUTABLE(upgraded upgraded.c watchdog.c)
+TARGET_LINK_LIBRARIES(upgraded ubox.a rt.a -static)
+set_target_properties(upgraded PROPERTIES LINK_SEARCH_END_STATIC 1)
+INSTALL(TARGETS upgraded
+ RUNTIME DESTINATION sbin
+)
+
+
ADD_EXECUTABLE(askfirst utils/askfirst.c)
INSTALL(TARGETS askfirst
RUNTIME DESTINATION sbin