summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-16 18:43:03 +0200
committerJohn Crispin <blogic@openwrt.org>2014-06-16 19:42:58 +0200
commit202318c6163657fc671b27527e5228cb8170af1d (patch)
tree3331a471a1760cdbabd80d5c7f2a93685d12e6c8 /CMakeLists.txt
parent9c9c71a4e476be1e93f4d4c2c0527b5df0ff3c90 (diff)
downloadunitd-202318c6163657fc671b27527e5228cb8170af1d.tar
unitd-202318c6163657fc671b27527e5228cb8170af1d.zip
move upgrade to its own subfolder
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b90cdd7..dc7ecd6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)
ENDIF()
+add_subdirectory(upgraded)
ADD_EXECUTABLE(procd ${SOURCES})
TARGET_LINK_LIBRARIES(procd ${LIBS})
@@ -42,14 +43,6 @@ INSTALL(TARGETS udevtrigger
)
-ADD_EXECUTABLE(upgraded upgraded.c watchdog.c)
-TARGET_LINK_LIBRARIES(upgraded ubox.a rt.a -static -lc -lgcc)
-set_target_properties(upgraded PROPERTIES LINK_SEARCH_END_STATIC 1)
-INSTALL(TARGETS upgraded
- RUNTIME DESTINATION sbin
-)
-
-
ADD_EXECUTABLE(askfirst utils/askfirst.c)
INSTALL(TARGETS askfirst
RUNTIME DESTINATION sbin