summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-03-08 23:52:52 +0100
committerJohn Crispin <blogic@openwrt.org>2013-03-13 18:58:14 +0100
commit6390afe7a3cf1663979078711febb2be21fb4cf2 (patch)
treefb1b589607a2c5b2d41f72c15b21ed38600a0e1c /CMakeLists.txt
parent0f479be2068d7fe3bd5953e7454aaabb2be38d93 (diff)
downloadunitd-6390afe7a3cf1663979078711febb2be21fb4cf2.tar
unitd-6390afe7a3cf1663979078711febb2be21fb4cf2.zip
add new main.c and fix Makefile/headers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 21 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc1ad3a..62e309a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,10 +10,10 @@ IF(APPLE)
LINK_DIRECTORIES(/opt/local/lib)
ENDIF()
-SET(SOURCES main.c ubus.c service.c instance.c utils.c md5.c hotplug-rule.c hotplug.c)
+SET(SOURCES main.c ubus.c service.c instance.c utils.c md5.c hotplug.c state.c mkdev.c early.c inittab.c preinit.c coldplug.c syslog.c log.c watchdog.c signal.c system.c debug.c)
find_library(json NAMES json-c json)
-SET(LIBS ubox ubus ${json} blobmsg_json)
+SET(LIBS ubox ubus ${json} blobmsg_json json_script)
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)
@@ -26,3 +26,22 @@ TARGET_LINK_LIBRARIES(procd ${LIBS})
INSTALL(TARGETS procd
RUNTIME DESTINATION sbin
)
+
+ADD_EXECUTABLE(askfirst askfirst.c)
+
+INSTALL(TARGETS askfirst
+ RUNTIME DESTINATION sbin
+)
+
+ADD_EXECUTABLE(udevtrigger udevtrigger.c)
+
+INSTALL(TARGETS udevtrigger
+ RUNTIME DESTINATION sbin
+)
+
+ADD_EXECUTABLE(logread logread.c)
+TARGET_LINK_LIBRARIES(logread ${LIBS})
+
+INSTALL(TARGETS logread
+ RUNTIME DESTINATION sbin
+)