summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-11-11 15:54:29 +0100
committerJohn Crispin <blogic@openwrt.org>2013-11-12 10:32:32 +0100
commitcd4af8eb78c30718f999c487c93e257bbd969cb1 (patch)
tree4efeb2684dbe11b153ed168198d31c6208744f95 /CMakeLists.txt
parent582c88fdb55e01f3814e9c09a860651ed51a659d (diff)
downloadunitd-cd4af8eb78c30718f999c487c93e257bbd969cb1.tar
unitd-cd4af8eb78c30718f999c487c93e257bbd969cb1.zip
add data type validator
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7b0808..5162610 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,9 +19,15 @@ IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)
ENDIF()
+ADD_LIBRARY(validate SHARED validate.c)
+
+INSTALL(TARGETS validate
+ LIBRARY DESTINATION lib
+)
+
ADD_EXECUTABLE(procd ${SOURCES})
-TARGET_LINK_LIBRARIES(procd ${LIBS})
+TARGET_LINK_LIBRARIES(procd ${LIBS} validate)
INSTALL(TARGETS procd
RUNTIME DESTINATION sbin
@@ -45,3 +51,10 @@ TARGET_LINK_LIBRARIES(logread ${LIBS})
INSTALL(TARGETS logread
RUNTIME DESTINATION sbin
)
+
+ADD_EXECUTABLE(validate_data validate_data.c)
+TARGET_LINK_LIBRARIES(validate_data ${LIBS} validate)
+
+INSTALL(TARGETS validate_data
+ RUNTIME DESTINATION sbin
+)