summaryrefslogtreecommitdiffstats
path: root/src/unitd/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-11-30 15:30:15 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-11-30 15:53:08 +0100
commitc44898bd9eea6a544c0c751f5435e6830d96fe32 (patch)
tree62b8a10dde81b4565f4de0940f6e9d6158e3315c /src/unitd/CMakeLists.txt
parentd905c9da4d8984f19cd74a17cebd2743d399b035 (diff)
downloadunitd-c44898bd9eea6a544c0c751f5435e6830d96fe32.tar
unitd-c44898bd9eea6a544c0c751f5435e6830d96fe32.zip
Set process name
Diffstat (limited to 'src/unitd/CMakeLists.txt')
-rw-r--r--src/unitd/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/unitd/CMakeLists.txt b/src/unitd/CMakeLists.txt
index 6ef73f6..e07528b 100644
--- a/src/unitd/CMakeLists.txt
+++ b/src/unitd/CMakeLists.txt
@@ -1,6 +1,6 @@
add_executable(unitd unitd.c signal.c watchdog.c state.c askconsole.c ubus.c system.c early.c
service/service.c service/instance.c utils.c)
-set_property(TARGET unitd PROPERTY COMPILE_FLAGS "-std=gnu99 -Wall ${JSON_C_CFLAGS_OTHER}")
+set_property(TARGET unitd PROPERTY COMPILE_FLAGS "-std=gnu99 -Wall -D_GNU_SOURCE ${JSON_C_CFLAGS_OTHER}")
set_property(TARGET unitd PROPERTY LINK_FLAGS "${JSON_C_LDFLAGS_OTHER}")
set_property(TARGET unitd PROPERTY INCLUDE_DIRECTORIES ${JSON_C_INCLUDE_DIR})
target_link_libraries(unitd ubox ubus blobmsg_json ${JSON_C_LIBRARIES})