summaryrefslogtreecommitdiffstats
path: root/upgraded/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-16 18:43:03 +0200
committerJohn Crispin <blogic@openwrt.org>2014-06-16 19:42:58 +0200
commit202318c6163657fc671b27527e5228cb8170af1d (patch)
tree3331a471a1760cdbabd80d5c7f2a93685d12e6c8 /upgraded/CMakeLists.txt
parent9c9c71a4e476be1e93f4d4c2c0527b5df0ff3c90 (diff)
downloadunitd-202318c6163657fc671b27527e5228cb8170af1d.tar
unitd-202318c6163657fc671b27527e5228cb8170af1d.zip
move upgrade to its own subfolder
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'upgraded/CMakeLists.txt')
-rw-r--r--upgraded/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/upgraded/CMakeLists.txt b/upgraded/CMakeLists.txt
new file mode 100644
index 0000000..7e08c0e
--- /dev/null
+++ b/upgraded/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(upgraded C)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+set(CMAKE_EXE_LINKER_FLAGS -static)
+set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+set(CMAKE_EXE_LINK_DYNAMIC_C_FLAGS)
+set(CMAKE_EXE_LINK_DYNAMIC_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS)
+ADD_EXECUTABLE(upgraded upgraded.c ../watchdog.c)
+TARGET_LINK_LIBRARIES(upgraded ubox rt)
+INSTALL(TARGETS upgraded
+ RUNTIME DESTINATION sbin
+)