summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c874d9..b6b0717 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,20 +5,6 @@ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
project(unitd C)
include(GNUInstallDirs)
-
find_package(JSON_C REQUIRED)
-
-add_executable(init unitd.c signal.c watchdog.c state.c askconsole.c ubus.c system.c early.c
- service/service.c service/instance.c utils/utils.c)
-set_property(TARGET init PROPERTY COMPILE_FLAGS "-std=gnu99 -Wall ${JSON_C_CFLAGS_OTHER}")
-set_property(TARGET init PROPERTY LINK_FLAGS "${JSON_C_LDFLAGS_OTHER}")
-set_property(TARGET init PROPERTY INCLUDE_DIRECTORIES ${JSON_C_INCLUDE_DIR})
-target_link_libraries(init ubox ubus blobmsg_json ${JSON_C_LIBRARIES})
-
-install(TARGETS init RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR})
-
-
-add_executable(askfirst utils/askfirst.c)
-
-install(TARGETS askfirst RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR})
+add_subdirectory(src)