summaryrefslogtreecommitdiffstats
path: root/src/unitd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/unitd/CMakeLists.txt')
-rw-r--r--src/unitd/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/unitd/CMakeLists.txt b/src/unitd/CMakeLists.txt
new file mode 100644
index 0000000..6ef73f6
--- /dev/null
+++ b/src/unitd/CMakeLists.txt
@@ -0,0 +1,8 @@
+add_executable(unitd unitd.c signal.c watchdog.c state.c askconsole.c ubus.c system.c early.c
+ service/service.c service/instance.c utils.c)
+set_property(TARGET unitd PROPERTY COMPILE_FLAGS "-std=gnu99 -Wall ${JSON_C_CFLAGS_OTHER}")
+set_property(TARGET unitd PROPERTY LINK_FLAGS "${JSON_C_LDFLAGS_OTHER}")
+set_property(TARGET unitd PROPERTY INCLUDE_DIRECTORIES ${JSON_C_INCLUDE_DIR})
+target_link_libraries(unitd ubox ubus blobmsg_json ${JSON_C_LIBRARIES})
+
+install(TARGETS unitd RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/unitd)