summaryrefslogtreecommitdiffstats
path: root/upgraded/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'upgraded/CMakeLists.txt')
-rw-r--r--upgraded/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/upgraded/CMakeLists.txt b/upgraded/CMakeLists.txt
new file mode 100644
index 0000000..7e08c0e
--- /dev/null
+++ b/upgraded/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(upgraded C)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+set(CMAKE_EXE_LINKER_FLAGS -static)
+set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+set(CMAKE_EXE_LINK_DYNAMIC_C_FLAGS)
+set(CMAKE_EXE_LINK_DYNAMIC_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS)
+ADD_EXECUTABLE(upgraded upgraded.c ../watchdog.c)
+TARGET_LINK_LIBRARIES(upgraded ubox rt)
+INSTALL(TARGETS upgraded
+ RUNTIME DESTINATION sbin
+)