summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d762cd7..17a8385 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,15 @@ find_package(libnm_glib REQUIRED)
set(PAM_MODULE_DIR "${CMAKE_INSTALL_PREFIX}/lib/security" CACHE STRING "PAM module directory")
set(PAM_WLAN_HELPER_DIR "${CMAKE_INSTALL_PREFIX}/lib/security/pam_wlan" CACHE STRING "pam_wlan_helper install directory")
+set(CONNECTION_TIMEOUT "10" CACHE STRING "Connection timeout")
+set(CONNECTION_ID "" CACHE STRING "Connection ID")
+set(CONNECTION_UUID "" CACHE STRING "Connection UUID")
+set(CONNECTION_SSID "" CACHE STRING "Connection SSID")
+set(CONNECTION_AUTH_ALG "open" CACHE STRING "Connection authentication algorithm")
+set(CONNECTION_KEY_MGMT "wpa-eap" CACHE STRING "Connection key management method")
+set(CONNECTION_EAP "ttls" CACHE STRING "Connection EAP method")
+set(CONNECTION_PHASE2_AUTHEAP "mschapv2" CACHE STRING "Connection EAP phase2 authentication method")
+
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${PAM_INCLUDE_DIR} ${LIBNM_GLIB_INCLUDE_DIRS})
link_directories(${LIBNM_GLIB_LIBRARY_DIRS})